samedi 30 mai 2020    || Inscription
BanniereAlertes
 
 

Notre sélection d'alertes et avis SSI.
Sources : US Cert, Cert EU, Cert FR, Cnil, VulDB.

mardi 16 octobre 2018

Linux Kernel up to 4.14.x/4.15.x/4.16.x/4.17.x/4.18.12 BPF Verifier kernel/bpf/verifier.c adjust_scalar_min_max_vals memory corruption

A vulnerability classified as critical was found in Linux Kernel up to 4.14.x/4.15.x/4.16.x/4.17.x/4.18.12. This vulnerability affects the function adjust_scalar_min_max_vals of the file kernel/bpf/verifier.c of the component BPF Verifier. The manipulation with an unknown input leads to a memory corruption vulnerability (Out-of-Bounds). The CWE definition for the vulnerability is CWE-119. As an impact it is known to affect confidentiality, integrity, and availability.

The weakness was published 10/17/2018. This vulnerability was named CVE-2018-18445 since 10/17/2018. There are known technical details, but no exploit is available. The current price for an exploit might be approx. USD $5k-$25k (estimation calculated on 10/18/2018).

Upgrading to version 4.18.13 eliminates this vulnerability.

Similar entries are available at 125737.

CPE

CVSSv3

VulDB Meta Base Score: 5.5
VulDB Meta Temp Score: 5.3

VulDB Base Score: ≈5.5
VulDB Temp Score: ≈5.3
VulDB Vector: 🔒
VulDB Reliability: 🔍

CVSSv2

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍

Exploiting

Class: Memory corruption / Out-of-Bounds (CWE-119)
Local: Yes
Remote: No

Availability: No

Price Prediction: 🔍
Current Price Estimation: 🔒

Threat Intelligence

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Actions: 🔍

Countermeasures

Recommended: Upgrade
Status: Official fix
0-Day Time: 🔒

Upgrade: Kernel 4.18.13

Timeline

10/17/2018 Advisory disclosed
10/17/2018 CVE assigned
10/18/2018 VulDB entry created
10/18/2018 VulDB last update

Sources

CVE: CVE-2018-18445 (🔒)
See also: 🔒

Entry

Created: 10/18/2018
Complete: 🔍

Lien vers l'article source

Auteur: VulDB

Catégories: VulDBNombre de vues: 196

x

Événements SSI