Notre sélection d'alertes et avis SSI.
Sources : US Cert, Cert EU, Cert FR, Cnil, VulDB.

dimanche 16 décembre 2018

VyOS 1.1.8 Default Configuration pppd Parameter privilege escalation

A vulnerability was found in VyOS 1.1.8 and classified as critical. Affected by this issue is an unknown function of the file pppd of the component Default Configuration. The manipulation as part of a Parameter leads to a privilege escalation vulnerability. Using CWE to declare the problem leads to CWE-269. Impacted is confidentiality, integrity, and availability. CVE summarizes:

A privilege escalation issue was discovered in VyOS 1.1.8. The default configuration also allows operator users to execute the pppd binary with elevated (sudo) permissions. Certain input parameters are not properly validated. A malicious operator user can run the binary with elevated permissions and leverage its improper input validation condition to spawn an attacker-controlled shell with root privileges.

The weakness was published 12/17/2018. The advisory is available at blog.vyos.io. This vulnerability is handled as CVE-2018-18556 since 10/22/2018. Technical details are known, but there is no available exploit. The structure of the vulnerability defines a possible price range of USD $0-$5k at the moment (estimation calculated on 12/18/2018).

There is no information about possible countermeasures known. It may be suggested to replace the affected object with an alternative product.

Similar entries are available at 128029.

CPE

CVSSv3

VulDB Meta Base Score: 5.5
VulDB Meta Temp Score: 5.5

VulDB Base Score: ≈5.5
VulDB Temp Score: ≈5.5
VulDB Vector: 🔒
VulDB Reliability: 🔍

CVSSv2

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍

Exploiting

Class: Privilege escalation (CWE-269)
Local: Yes
Remote: No

Availability: No

Price Prediction: 🔍
Current Price Estimation: 🔒

Threat Intelligence

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Actions: 🔍

Countermeasures

Recommended: no mitigation known
0-Day Time: 🔒

Timeline

10/22/2018 CVE assigned
12/17/2018 Advisory disclosed
12/18/2018 VulDB entry created
12/18/2018 VulDB last update

Sources

Advisory: blog.vyos.io

CVE: CVE-2018-18556 (🔒)
See also: 🔒

Entry

Created: 12/18/2018
Complete: 🔍

Lien vers l'article source

Auteur: VulDB

Catégories: VulDBNombre de vues: 254

x

Événements SSI