Notre sélection d'alertes et avis SSI.
Sources : US Cert, Cert EU, Cert FR, Cnil, VulDB.

jeudi 11 juillet 2019

MiniMagick up to 4.9.3 lib/mini_magick/image.rb Image.open Image File privilege escalation

A vulnerability classified as critical has been found in MiniMagick up to 4.9.3. This affects the function Image.open in the library lib/mini_magick/image.rb. The manipulation as part of a Image File leads to a privilege escalation vulnerability. CWE is classifying the issue as CWE-269. This is going to have an impact on confidentiality, integrity, and availability.

The weakness was released 07/12/2019. This vulnerability is uniquely identified as CVE-2019-13574 since 07/11/2019. Technical details are known, but no exploit is available.

Upgrading to version 4.9.4 eliminates this vulnerability.

Product

Name

CPE 2.3

CPE 2.2

CVSSv3

VulDB Meta Base Score: 5.5
VulDB Meta Temp Score: 5.3

VulDB Base Score: ≈5.5
VulDB Temp Score: ≈5.3
VulDB Vector: 🔒
VulDB Reliability: 🔍

CVSSv2

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍

Exploiting

Class: Privilege escalation (CWE-269)
Local: Yes
Remote: No

Availability: 🔒
Status: Not defined

Price Prediction: 🔍
Current Price Estimation: 🔒

Threat Intelligence

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Remediation: 🔍

Countermeasures

Recommended: Upgrade
Status: 🔍

0-Day Time: 🔒

Upgrade: MiniMagick 4.9.4

Timeline

07/11/2019 CVE assigned
07/12/2019 Advisory disclosed
07/12/2019 VulDB entry created
07/12/2019 VulDB last update

Sources


CVE: CVE-2019-13574 (🔒)

Entry

Created: 07/12/2019 09:37 AM
Complete: 🔍

Lien vers l'article source

Auteur: VulDB

Catégories: VulDBNombre de vues: 230

x

Événements SSI